Шпаргалка 1с8

Это не большая шпаргалка для меня.

#Соединения

Параметры = «Srvr=»»ххх»»;Ref=»»ххх»»;Usr=»»ххх»»;Pwd=»»ххх»»;
//Параметры = «File = «»С:\MyBase»»; Usr = ***; Pwd = ***»;
COMConnector= Новый COMОбъект(«V83.COMConnector»);
Попытка  Соединение = COMConnector.Connect(Параметры);
Сообщить(«ОКАЙ!»);
Исключение
Сообщить(«Ошибка подключения!»);
Возврат;
КонецПопытки;

#Запросы

Таблица значений в качестве параметра

«ВЫБРАТЬ
|ВнешняяТаблица.Ссылка КАК Номенклатура
|ПОМЕСТИТЬ В ВнешняяТаблица
|ИЗ
|ВнешняяТаблица КАК &ВнешняяТаблица»;
Запрос.УстановитьПараметр(«ВнешняяТаблица», ТЗ);

Условие в запросе
|И ВЫБОР
| КОГДА &Валюта = НЕОПРЕДЕЛЕНО
| ТОГДА ИСТИНА
| ИНАЧЕ Валюта = &Валюта
| КОНЕЦ

|ВЫБОР
|КОГДА
|&Валюта = НЕОПРЕДЕЛЕНО
|ТОГДА ХозрасчетныйОбороты.СуммаОборотКт
|ИНАЧЕ
|ХозрасчетныйОбороты.ВалютнаяСуммаОборотКт
|КОНЕЦ = 0
Результат = Запрос.ВыполнитьПакет();Результат = Запрос.ВыполнитьПакет();ПараметрыПроведения.Вставить(НомерТаблицы.Ключ, Результат[НомерТаблицы.Значение].Выгрузить());

| И НЕ Работники.Регистратор.Комментарий Подобно «»%график%»»

|ГДЕ
| ТИПЗНАЧЕНИЯ(КонстантыДинамические.Значение) = ТИП(Справочник.ПодразделенияОрганизаций)

 

/c ЗапуститьОбновлениеИнформационнойБазы

ТЗ.Колонки.Добавить(«ИндексСортировки» , Новый ОписаниеТипов(«Число»));
ТЗ.Колонки.Добавить(«ИмяРаздела» , Новый ОписаниеТипов(«Строка»));
ТЗ.Колонки.Добавить(«ДатаКорр» , Новый ОписаниеТипов(«Дата»));
ТЗ.Колонки.Добавить(«БезусловноеУдаление» , Новый ОписаниеТипов(«Булево»));
ТЗ.Колонки.Добавить(«Номенклатура» , Новый ОписаниеТипов(«СправочникСсылка.Номенклатура»));
ТЗ.Колонки.Добавить(«ДанныеРаздела» , Новый ОписаниеТипов(«Структура»));
// пример создания колонок «число» и «строка» с уточнением параметров:
ТЗ.Колонки.Добавить(«ПроцентВыполнения» , Новый ОписаниеТипов(«Число» , Новый КвалификаторыЧисла(18, 2)));
ТЗ.Колонки.Добавить(«ИмяРаздела» , Новый ОписаниеТипов(«Строка» , , Новый КвалификаторыСтроки(200, ДопустимаяДлина.Переменная)));
ТЗ.Колонки.Добавить(«ДатаСписания» , Новый ОписаниеТипов(«Дата» , , , Новый КвалификаторыДаты(ЧастиДаты.ДатаВремя)));

Запрос.УстановитьПараметр(«НаДату», Новый Граница(КонецДня(НаДату),ВидГраницы.Включая));

#Документы
Как программно проверить что документ новый.
&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если Параметры.Ключ.Пустая() Тогда Объект.Ответственный = ПараметрыСеанса.ТекущийПользователь;
КонецЕсли;

#Дата
Дата = '20180804'; // 04.08.2018
Дата = Дата("20180804"); // 04.08.2018
Дата = Дата(2018, 08, 4); // 04.08.2018
Дата = '20180804092506'; // 04 августа 2018 г. 9 ч. 25 мин. 6 сек.

Если Дата = '00010101' Тогда
Если Дата = '00010101000000' Тогда
Если Дата = '0001-01-01' Тогда
Если Дата = Дата(1, 1, 1) Тогда

РАЗНОСТЬДАТ(ДАТАВРЕМЯ(2005, 09, 12), ДАТАВРЕМЯ(2005, 09, 10), ДЕНЬ)
Вернет «-2»

#СписокЗначений

Для Каждого Элемент Из Список Цикл
    Сообщить(Элемент.Значение);
КонецЦикла;
Для Индекс = 0 По Список.Количество() - 1 Цикл
    Сообщить(Список[Индекс]);
КонецЦикла;

Ваш отзыв

Метки: